Announcement

Collapse
No announcement yet.

hey eerybody I NEED HELP

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • prkchp76
    replied
    ok i hope yall are talking about registering on the polaris site if so ues i have been there about three weeks now same name i have replaced the switch the armatures in both sides and nothing i have power all the way to the wheel on both sides also tried bypassing speedo that didnt work either

    Leave a comment:


  • rsanders
    replied
    Just by chance , have you checked the switch ? Sometimes it's the simple things that is overlooked. What year is yours ? I Have a 2005 500 Sportsman HO . I'm going down where it is the first of the week and will look at mine to see if there would be anything obvious, it sometimes helps to look when you're not the one with the problem. But first go register :D :D :D

    Leave a comment:


  • prkchp76
    replied
    thx man i will doo when you wanna meet up and go riding for the weekend

    Leave a comment:


  • Long_Hunter
    replied
    Register on this forum and post up your problem; you will get an answer as there are some very smart bubbas on this forum. I have two Polaris 500s, but have never had any significant issues with them.

    http://www.polarisatvforums.com/forums/


    RLTW!
    LH

    Leave a comment:


  • prkchp76
    started a topic hey eerybody I NEED HELP

    hey eerybody I NEED HELP

    i recently traded for a 01 500 polaris sportsman the f 4x4 will not work i have replaced coils have power i am stumped help any one
Working...
X